Notification

Retirement of TLS 1.0 & 1.1 Browser Support



Please be aware of a networking change Skillsoft is making in order to remain compliant with security policies and industry best practices.

What is Skillsoft changing?
Skillsoft will be disabling TLS 1.0 and 1.1 for all hosted web services as of June 1, 2018. All connections to Skillsoft hosted web services will require TLS 1.2 after June 1st. As a result of this change, Skillsoft will also be dropping support for older versions of Internet Explorer which do not support TLS 1.2 (IE8, IE9, and IE10), as well as the Windows XP operating system, and Java Runtime Environment (JRE) version 1.7.

What is TLS and why is Skillsoft making this change?
TLS (Transport Layer Security) is a cryptographic protocol that encrypts communication over secure web connections (HTTPS). TLS 1.0 and 1.1 have been demonstrated to be vulnerable to exploit and attack. In order to protect our customers´ data and in alignment with industry-wide best practices, Skillsoft will only support TLS 1.2 as of June 1, 2018.

What do I need to do?
The change should be transparent to any users that are using a modern browser that supports TLS 1.2. See below for the list of browsers that Skillsoft supports. Browsers and other systems that do not support TLS 1.2 will be unable to connect to Skillsoft hosted services as of June 1, 2018.

Integrations with your learning management system (LMS) or other learning platforms that use Skillsoft APIs (OLSA Web services or BCS) to connect to Skillsoft hosted services must support TLS 1.2. If you have built or if you use a third-party system that uses an integration to any Skillsoft APIs (such as OLSA automation with an LMS), you should verify that they support TLS 1.2. This includes features such as OLSA asset or catalog synchronization, progress data export, and batch user maintenance.

Skillsoft has verified with the following vendors that they already support TLS 1.2. If you use one of the following, your system should have no problems with this change:

• Degreed
• Saba
• SuccessFactors
• SumTotal Learn
• SumTotal Maestro
• SumTotal Pathlore
• Workday

If you are using a different system that has an API integration with Skillsoft services (OLSA or BCS), please contact your vendor to make sure their implementation is capable of supporting TLS 1.2.

Skillsoft Supported Browsers
Skillsoft supports the following browsers, which all support TLS 1.2:

• Microsoft Edge v14+ (Windows 10 only)
• Microsoft Internet Explorer 11 (Windows 7, 8.1, 10)
• Google Chrome v63+ (Windows 7, 8.1, 10)
• Mozilla Firefox v52+ (Windows 7, 8.1, 10)
• Apple Safari v10.1+ (macOS only)

Skillsoft will be dropping support for Microsoft Internet Explorer versions 10 and earlier, which do not support TLS 1.2 by default. Users attempting to use a browser that does not support TLS 1.2 will be unable to connect to Skillsoft hosted services after June 1, 2018.

We appreciate you may have questions about this upcoming change affecting your hosted solution. Skillsoft is here to help. If you have any questions or concerns about these changes, please contact our Technical Support team at support@skillsoft.com.
"Through a number of years I have had access to online training. Since my calendar is always filled, I have difficulty finding time for traditional courses. "
Elfac A/S
Henrik Lynnerup
IT Manager
News letter
By visiting www.2masterit.com you accept our use of cookies, which we and our partners use to improve functionality, statistics and marketing. Read more about our use of cookies at www.2masterit.com